Monday, September 25, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  5] [ 0]  / answers: 1 / hits: 3094  / 6 Months ago, fri, april 14, 2023, 9:53:23

After Ubuntu upgrade to 22.04, the printer Nashuatech Aficio MPC2051 print only in Black/White and doesn't print in COLOR mode:

I tried to reinstall drivers.

In Ubuntu printer setup if i select 'Color' then reopening Ubuntu printer setup I always find 'Grayscale'. It doesn't store 'Color' mode.

I tried running Bash file :

lp -o ColorModel=Color -o media=a4 -o fit-to-page "test_color.pdf"

I tried also using Generic Printer Drivers.

But always print in B/W.

With 21.10 the printer works also in color mode.

Driver selection window

More From » drivers


Thanks to TontonManu that gave me the way.

My solution has been:

open ubuntu printer setup (pulldown menu from top right);

open additional printer setup (clicking on button right side);

open printer property from 'Printer - localhost' (right click on the printer icon);

select 'opzioni lavoro' (job option) schedule;

in this schedule select 'color' in the 'print-color-mode' field (it was monochrome by default).schedule selection

Now it's ok.

(PS: Only for notice using PDF drivers not working at all neither B/W)

[#472] Friday, April 14, 2023, 6 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 69
Total Questions: 116
Total Answers: 122

Location: Honduras
Member since Sun, Dec 26, 2021
2 Years ago