Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
6
rated 0 times [  6] [ 0]  / answers: 1 / hits: 7165  / 1 Year ago, fri, february 10, 2023, 10:31:02

Steam process is showing in System Monitor, but UI is not launching.


More From » steam

 Answers
6

Issue seems to be solved now. I changed the graphics from nvidia-510 to nvidia-470 in Software and Updates.


I removed earlier installs:


sudo apt remove steam steam-launcher steam-installer
sudo apt purge steam steam-launcher steam-installer

sudo rm -rf ~/.local/share/steam
sudo rm -rf ~/.steam
sudo rm ~/.steampath
sudo rm ~/.steamid
sudo rm -rf Steam
sudo rm -rf /usr/lib/steam

Then installed steam via wget


sudo dpkg --add-architecture i386

sudo apt update
sudo apt install wget gdebi-core libgl1-mesa-glx:i386

wget -O ~/steam.deb http://media.steampowered.com/client/installer/steam.deb

sudo gdebi ~/steam.deb

Then ran steam via terminal


steam

This solved my problem!


P.S.


Also, when I ran steam through terminal, an error was shown:



Could not connect to X session manager: None of the authentication
protocols specified are supported



For this, a solution was mentioned on the steam website to check $DISPLAY


echo $DISPLAY
DISPLAY=:0 steam

Don't have much idea what this is (I AM NEW to Ubuntu and anything open-source). This might help if nothing above this helps.


[#485] Saturday, February 11, 2023, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
fieldcheon

Total Points: 24
Total Questions: 105
Total Answers: 109

Location: Western Sahara
Member since Tue, Feb 16, 2021
3 Years ago
fieldcheon questions
Fri, Apr 1, 22, 05:58, 2 Years ago
Wed, Feb 2, 22, 03:31, 2 Years ago
Sat, Aug 14, 21, 01:24, 3 Years ago
Sat, Aug 28, 21, 21:21, 3 Years ago
;