Tuesday, October 3, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  18] [ 0]  / answers: 1 / hits: 3178  / 11 Months ago, sat, december 3, 2022, 9:31:19

I use F12 key to open guake terminal. Whenever I press F12 key it doesn't work. However, no function keys are working if I am at desktop or at file manager.

Is there any solution for it?

Thank you.

More From » 22.04


The reason that it does not work is because Ubuntu now is running on Wayland instead of Xorg. One of the security measures of Wayland - which in fact is crippling functionality - is that applications are not anymore allowed to globally listen for shortcut keys.

Some applications cannot run on Wayland. For these, Wayland provides an emulation layer, xwayland. As long as an application running on xwayland is in the foreground, your function key will work. If a native Wayland application is in the foreground, your function key will not work.

There are two possible options

Option 1: Check whether Guake terminal provides a command line option to have it open/close. A very quick search learned me that there is an -s or --show-hide option. Remove the hotkey setting within the preferences of Quake itself, and instead create a shortcut in "Settings" - "Keyboard shortcuts" where you specify the command guake -s.

Option 2: Log in on an Xorg session instead. All will work as previously.

[#548] Sunday, December 4, 2022, 11 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 358
Total Questions: 112
Total Answers: 119

Location: Cayman Islands
Member since Fri, Mar 4, 2022
2 Years ago
eighethod questions
Thu, Sep 1, 22, 00:56, 1 Year ago
Wed, May 24, 23, 07:59, 5 Months ago
Thu, Feb 10, 22, 01:13, 2 Years ago
Thu, Oct 28, 21, 14:51, 2 Years ago