Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 556  / 2 Years ago, mon, october 31, 2022, 9:39:22

I'm on 20.04 Desktop, dual booting on a laptop with Windows.


Everything else works fine, but pressing the super key on my keyboard does nothing. I can press Super+A and it brings up the app overview no problem, but the super button by itself does nothing.


Going into Settings > Region & Language > Input Sources, my one and only keyboard is correctly set to English (US). However, clicking the little eye icon next to it that brings up the onscreen display of which button is being pressed, when I tap the super key on my keyboard (which is located to the left of the spacebar), Super R is the key that is highlighted onscreen.


Any ideas what's happening here?


More From » keyboard

 Answers
4

There indeed appears to be a discrepancy between the standard keyboard layout definition you use and your physical keyboard. Your (only) Super key appears to emit keycode 134 rather than 133, so by default is mapped to Super_R rather than Super_L.


Modifying a keyboard layout involves editing source files. There is, however, an easy way to have your Super key reveal the Activities overview without changing more fundamental configurations. Issue the following command to have Super_R trigger the overview rather than Super_L:


gsettings set org.gnome.mutter overlay-key 'Super_R'

You can reset to the default setting by changing set by reset and leaving out 'Super_R'.


[#884] Wednesday, November 2, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
brailloni

Total Points: 122
Total Questions: 108
Total Answers: 108

Location: North Korea
Member since Tue, Apr 4, 2023
1 Year ago
brailloni questions
Tue, Jun 21, 22, 21:51, 2 Years ago
Thu, Jul 29, 21, 05:25, 3 Years ago
Sat, Apr 2, 22, 17:32, 2 Years ago
Fri, Dec 17, 21, 23:58, 2 Years ago
;