Saturday, September 30, 2023
 Popular · Latest · Hot · Upcoming
3
rated 0 times [  3] [ 0]  / answers: 1 / hits: 792  / 8 Months ago, tue, february 28, 2023, 2:52:54

I am struggling with this problem for few days.


I have Ubuntu 20.04 installed with ubuntu-mate-desktop. When I suspend the system, on resume it does not ask for password.


Is there any way to set it so for recovering system will pop-up password window?


More From » 20.04

 Answers
6

I found this solution that worked for me.


First, create file /etc/systemd/system/lock.service as root:


[Unit]
Description="Make extra sure to lock the screen when suspending"

[Service]
Type=oneshot
User=root
ExecStart=/bin/loginctl lock-sessions

[Install]
WantedBy=suspend.target

Then, in order to to update system configuration, ‚Äčtype in console:


sudo systemctl daemon-reload
sudo systemctl enable lock.service

[#887] Tuesday, February 28, 2023, 8 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
ideobedi

Total Points: 121
Total Questions: 108
Total Answers: 107

Location: United States Minor Outlying Island
Member since Sat, May 28, 2022
1 Year ago
ideobedi questions
;