Saturday, December 2, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  9] [ 0]  / answers: 1 / hits: 388989  / 1 Year ago, wed, august 3, 2022, 9:46:27

I recently bought a shiny new Lenovo Yoga 2 Pro and I want to dual boot it with Ubuntu for studying purposes. Its built-in OS is Windows 8.1 and it has a 256GB SSD.

I've made a separate 90GB partition just for Ubuntu and a live USB to install it.

The first time everything seemed to work great, I solved the wifi issued by blacklisting ideapad_laptop, the installation went flawlessly and Ubuntu worked fine.

When I got up the next morning and turned on my laptop it booted into Windows right away without ever showing the GRUB menu. So I tried to reset, and checked my partitions with the Disk Manager and everything looked fine. Since I couldn't find a solution online I went ahead and formatted the partition to try and install again. This time and every time since, the installation was aborted and I got a fatal error saying:

Unable to install GRUB in /dev/sda
Executing `grub-install /dev/sda` failed.
This is a fatal error.

Can anyone please suggest a solution to this problem?
If any further information is needed I would be happy to provide it.

When installing I get the following in details:

ubuntu kernel: [ 1946.372741] FAT-fs (sda2): error, fat_get_cluster: invalid cluster chain (i_pos 0).
ubuntu grub-installer: error: Running 'grub-install --force failed.

More From » grub2


I finally got it working, not sure which of the following did the trick but I:

  1. Disabled Lenovo Fast Boot in BIOS.

  2. Disabled Secure Boot in BIOS.

  3. Booted from Live USB.

  4. In boot menu Added backlight=vendor in Try Ubuntu configuration text just before quiet splash.

  5. Chose Try Ubuntu.

  6. In terminal ran sudo rmmod ideapad_laptop to enable wifi.

  7. Ran installation and chose to install updates during installation.

  8. EFI partition was selected automatically so I assigned 9700MB for swap space and 80GB for Ubuntu.

  9. After installation completed added backlight=vendor to /etc/default/grub before quiet splash and then ran sudo update-grub.

  10. Blacklisted ideapad_laptop to enable wifi.

  11. Works fine so far. Thanks to everyone for the help!

[#25485] Wednesday, August 3, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 423
Total Questions: 121
Total Answers: 115

Location: Chad
Member since Wed, Sep 30, 2020
3 Years ago