Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
5
rated 0 times [  5] [ 0]  / answers: 1 / hits: 8485  / 2 Years ago, fri, august 5, 2022, 8:56:42

I'm getting some strange errors lately whenever trying to apt-get install anything. Here's an example from trying to install fluidsynth.



$ sudo apt-get install libfluidsynth1
Reading package lists... Done
Building dependency tree
Reading state information... Done
libfluidsynth1 is already the newest version.
libfluidsynth1 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up postgresql-9.1 (9.1.10-0ubuntu12.04) ...
* Starting PostgreSQL 9.1 database server * The PostgreSQL server failed to start. Please check the log output:
2013-11-03 14:21:42 EST FATAL: could not access private key file "server.key": No such file or directory
[fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error processing postgresql-9.1 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql:
postgresql depends on postgresql-9.1; however:
Package postgresql-9.1 is not configured yet.
dpkg: error processing postgresql (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
postgresql-9.1
postgresql
E: Sub-process /usr/bin/dpkg returned an error code (1)


I'm running 12.04. What's causing this and how do I address it? It happens for installing lots of things, and seems to suggest I need to initialize postgresql or something. I don't recall having fiddled with postgres, so I'm not sure why this suddenly became problematic.


More From » apt

 Answers
6

Remove/purge postgresql-9.1 and reinstall them:



sudo apt-get --purge autoremove postgresql-9.1 postgresql


If you really use postgresql, or another package depends of it, you can install it again



sudo apt-get install postgresql the-other-program-that-got-removed


BTW, libfluidsynth1 is already installed, you don't need to install it again.


[#28583] Saturday, August 6, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
kneducator

Total Points: 226
Total Questions: 111
Total Answers: 108

Location: Mexico
Member since Sun, Jul 25, 2021
3 Years ago
;