Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
2
rated 0 times [  2] [ 0]  / answers: 1 / hits: 4021  / 3 Years ago, wed, august 4, 2021, 10:36:42

I am trying to send all local mail to a single external e-mail, using Google's SMTP servers (I got that working following this nice tutorial).



Using Google's SMTP servers work, as I am able to send mail to external addresses work using mail from mailutils.



The redirection of local mail to the external e-mail does not work. When sending a mail to root from my account test using:



echo "Body" | mail -s "Test Postfix To Root" root



  • I never recieve the message

  • Nothing new turns up in /var/log/mail.err

  • This turns up in /var/log/mail.log



Sep  4 18:48:06 desktop1204test postfix/pickup[5535]: C9326EE26: uid=1000 from=
Sep 4 18:48:06 desktop1204test postfix/cleanup[5702]: C9326EE26: message-id=
Sep 4 18:48:06 desktop1204test postfix/qmgr[5534]: C9326EE26: from=, size=401, nrcpt=1 (queue active)
Sep 4 18:48:06 desktop1204test postfix/local[5704]: C9326EE26: to=, orig_to=, relay=local, delay=0.03, delays=0.02/0/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
Sep 4 18:48:06 desktop1204test postfix/qmgr[5534]: C9326EE26: removed


My /etc/postfix/main.cf:



inet_interfaces = loopback-only
mynetworks = loopback-only
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
## I commented the below two lines out, as they conflicted with the accepted answer
####virtual_alias_domains = localhost.localdomain
####virtual_alias_maps = hash:/etc/postfix/virtual
relayhost = [smtp.gmail.com]:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_tls_CAfile = /etc/postfix/cacert.pem
smtp_use_tls = yes


My etc/aliases:



# See man 5 aliases for format
postmaster: root


My /etc/postfix/virtual:



@localhost.localdomin        [email protected]


How can I get it working? I don't want any local mail to arrive locally, they should all go to [email protected].


More From » postfix

 Answers
2

This can be accomplished via virtual regexp (/etc/postfix/virtual-regexp)



/.+@.+/ [email protected]


then in main.cf:



virtual_maps = hash:/etc/postfix/virtual, regexp:/etc/postfix/virtual-regexp


and the mapfile:



postmap /etc/postfix/virtual-regexp


That should do the trick for all local mails (otherwise you must specify all addresses on virtual)


[#29611] Friday, August 6, 2021, 3 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
nalystcul

Total Points: 390
Total Questions: 106
Total Answers: 115

Location: Tokelau
Member since Sun, May 7, 2023
10 Months ago
nalystcul questions
Sun, May 1, 22, 17:05, 2 Years ago
Mon, Sep 6, 21, 08:12, 3 Years ago
Fri, Mar 18, 22, 20:06, 2 Years ago
;