Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
6
rated 0 times [  6] [ 0]  / answers: 1 / hits: 9914  / 2 Years ago, thu, november 3, 2022, 1:44:05

I backup files on Ubuntu 12.04 to the external drives.



The WD external drive works well.



But the Maxell external drive cannot recongnize some files names, such as the saved .html files with '|' or '/'.
But these files names are fine in Ubuntu, and these names are automatically saved when I save from opened html pages.



I do not want to change them one by one.



Any solution?


More From » filesystem

 Answers
7

Modern file systems can cope with almost all Unicode characters except the so called /NULL character.



However in case we do need to store files on a drive formatted with an older file system such as FAT32 we may run into issues. File names containing reserved characters |?*<":>+[]/ may then not be recognized.



Therefore even if today there is no need for this it still is good practice to avoid those characters in file names.



Whenever we run into file name issues we have the choice to




  • rename file containing reserved characters.

  • re-format this drive with a more modern file system.



If we need to occasionally share these file with Windows we should then format the external drive to NTFS. Only if the data are exclusively accessed from Ubuntu (or other Posix operating systems) we may prefer to choose ext4.




[#29928] Friday, November 4, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
sigtestim

Total Points: 298
Total Questions: 108
Total Answers: 106

Location: Bermuda
Member since Thu, Apr 20, 2023
1 Year ago
;