Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
rated 0 times [  4] [ 0]  / answers: 1 / hits: 37199  / 2 Years ago, sun, february 27, 2022, 10:08:53

How to associate file types with Sublime Text 2? have downloaded Sublime Text 2. I've unpacked it in /opt/Sublime Text 2/ directory.

Now I want to open all .conf files with ST2. But I can't set this easily. Xubuntu doesn't offer ST2 in the list of Open With programs.

I do:

right-click on the fonts.conf >> Properties... >> Open With >> Other Application.

And an Open With window appears. And it doesn't have ST2 application.

How either to add ST2 to the Open With list or how to associate a file with ST2?


Similar questions and are not answered:

associate program to a file where program is not in list

How to associate file types with Sublime Text 2?

why are simple things getting hard in Ubuntu (Xubuntu)?

More From » xubuntu


I found this way. And without any command line typing, which is good.

  1. In "File Manager" right click on a file (e.g. file.conf) you want to be opened by Sublime Text 2 (or any other application).

  2. Choose "Properties". A window titled file.conf - Properties should appear.

  3. In its tab "General" click "Open With:" and then choose "Other Application...". A window titled Open With should appear.

  4. At the bottom of this window select "Use a custom command:" option and then "Browse...".

  5. Browse to the necessary executable, Sublime Text 2, for example.

The most important part now: before click Ok put the selected path into double quotes, e.g.:

"/opt/Sublime Text 2/sublime_text"

because otherwise it cannot accept the path .

[#30415] Sunday, February 27, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 390
Total Questions: 106
Total Answers: 115

Location: Tokelau
Member since Sun, May 7, 2023
10 Months ago
nalystcul questions
Sun, May 1, 22, 17:05, 2 Years ago
Mon, Sep 6, 21, 08:12, 3 Years ago
Fri, Mar 18, 22, 20:06, 2 Years ago