Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
61
rated 0 times [  61] [ 0]  / answers: 1 / hits: 86735  / 1 Year ago, sun, december 25, 2022, 11:38:12

I set export UNITY_LOW_GFX_MODE=1 in my ~/.xprofile and it no longer has any effect in 13.04. Is there a way to disable all the eye candy? I'm running in VirtualBox and the Unity 3D mode with all the visual effects is overwhelming for the VM. Unity works and is usable, it's just very slow to render, so I'd rather have it off (is this 2D mode?).


More From » unity

 Answers
2

Especially on a low end machine such as mine (Athlon dual core, GForce 210) running Ubuntu with Unity and Compiz enabled is quite a challenge and may result in a rather slow and sluggish experience.


Virtual machine settings


To improve this I gave the following settings to the virtual machine:



  • enable VT-x/AMD-V, Nested Paging



  • 2 CPU (from dual core host) with an execution cap at 90% to ensure host operability



  • 2048 Base Memory



  • 256 MB Video Memory


      VBoxManage modifyvm "Name of VM" --vram 256


  • 3D Acceleration enabled



  • Guest Additions installed




Remove desktop effects


Then I observed a very slow animation for windows and menus. This animations did more harm than use in my virtual machine. Below is three methods how to disable them to get a smoother experience in Virtual Box:


Disable animations with Unity Tweak Tool or Gnome Tweak Tool


With both tools we can disable desktop animations:


enter image description here

GNOME tweak tool


enter image description here

Unity tweak tool


Compiz Config Settings Manager


As this is a virtual machine with the option to make a snapshot before you do harmful things to your OS you may probably safely runs ccsm to disable Compiz effects:


enter image description here



Do not disable windows decoration above



Dconf Editor


Lastly here is how to do it with dconf-editor:



  • Browse to org.compiz.profiles.default.core and remove the following from active profiles:


      'animations' 'fade'


  • Browse to org.compiz.profiles.unity.core and remove the following from active profiles:


      'animations'



Unfortunately I have found no way to disable the Dash animation, which still will be rather slow.


GNOME Session Flashback


In the likely case you are still not happy with the overall speed of the desktop you may consider installing the GNOME Session Flashback, which will let you log into GNOME Flashback (Compiz or Metacity) with a lean and fast desktop reminiscent of 10.04, but with all the upgraded applications, and the recent kernel:


enter image description here


enter image description here

Login 16.04


enter image description here

Login > 17.10


enter image description here


[#31436] Tuesday, December 27, 2022, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
nalystcul

Total Points: 390
Total Questions: 106
Total Answers: 115

Location: Tokelau
Member since Sun, May 7, 2023
10 Months ago
nalystcul questions
Sun, May 1, 22, 17:05, 2 Years ago
Mon, Sep 6, 21, 08:12, 3 Years ago
Fri, Mar 18, 22, 20:06, 2 Years ago
;