Thursday, September 28, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  1] [ 0]  / answers: 1 / hits: 11365  / 2 Years ago, fri, may 7, 2021, 10:17:20

I got a new USB Wi-Fi adapter (ASUS AC1200 USB-AC53 Nano) and have failed to make it work in Ubuntu 18.04. I've tried now a lot of possible solutions such as this and also installation from this repo but the OS still fail to recognize the Wi-Fi adapter. I can see it when lsusb though. The solutions tried so far compiled and installed correctly. After that I reboot the PC and it stays in the closing Ubuntu screen and I have to turn it off manually. After turning it on again nothing happens. It is just that the Wi-Fi adapter is not recognized. I'd appreciate your help


At this point I made a fresh installation of Ubuntu 18.04. The following is the output of lsusb. There's no 8822bu module because after the fresh installation I haven't tried any of the drivers yet. Which one you recommend me to try first?

Bus 002 Device 002: ID 0bda:0328 Realtek Semiconductor Corp.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 413c:301a Dell Computer Corp.
Bus 001 Device 002: ID 413c:2113 Dell Computer Corp.
Bus 001 Device 004: ID 0b05:184c ASUSTek Computer, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Kernel version:


More From » wireless


I recommend this git repository:

It compiles with a few possibly harmless warnings on my 5.3.xx system.

The procedure is outlined clearly at the github page but if you get stuck, please post back and I'll help.

[#3824] Sunday, May 9, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 255
Total Questions: 105
Total Answers: 118

Location: Virgin Islands (U.S.)
Member since Sat, May 6, 2023
5 Months ago