Saturday, December 2, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  6] [ 0]  / answers: 1 / hits: 3037  / 2 Years ago, fri, september 24, 2021, 10:19:47

Just upgraded to 22.04 and the ebook viewer is unable to open .mobi file with ebook viewer error message:

calibre, version 5.41.0
ERROR: Render process crashed:
The Qt WebEngine Render process has crashed.
You should try restarting the viewer.

I've tried this before and after Calibre update and is getting the same result.

Bug report filed


as recommended by @andrew.46, using the repository version will resolve the problem. Kindly scroll down to view his answer for a complete walk-thru.

More From » ebooks


Normally the best advice with Calibre is to follow the directions of Kovid Goyal (the Calibre developer) and use the binary edition available on the Calibre web site.

However currently there is an issue either with this version: 5.41.0 or with its interaction with glibc and/or QT on the host system leading to this error:

enter image description here

This can be worked around by running Calibre and its associated applications with:


But this is an ugly hack and seems to have a few ill effects on the running of Calibre on Ubuntu 22.04. Fortunately the repository version 5.37.0 runs perfectly and can be installed from the Software Center, Synaptic or simply from the command line as:

sudo apt-get install calibre

And then we can all get back to reading :).

[#646] Friday, September 24, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 490
Total Questions: 101
Total Answers: 110

Location: Guadeloupe
Member since Mon, Jan 24, 2022
2 Years ago
herfor questions