Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
0
rated 0 times [  0] [ 0]  / answers: 1 / hits: 1929  / 2 Years ago, tue, june 21, 2022, 9:51:04

I have installed Ubuntu server 22.04 for the first time and am still pretty new to linux. Every time I reboot the server I will have to run the command sudo ifconfig enp6s0f1 upto get that interface up and running. (I have learned after reading through forums that I should start using ip commands) I have edited my netplan .yaml file and will include it. I have my main interface which doesn't have this issue and a phone tethered to the server that I also do not have this issue with. I've read around and still can't seem to find the solution to my problem. Any advice is greatly appreciated and thank you for your time.


 network:
version: 2
renderer: networkd
ethernets:
enp0s25:
dhcp4: true
enp6s0fl:
dhcp4: false
usb0:
dhcp4: false

More From » networking

 Answers
1

It seems your .yaml file has some errors.


First, if you expect your interface to get an IP-address, dhcp4 should be set to true.


Also, you have the wrong name for your interface - you have written enp6s0fl, where it should be enp6s0f1. (Maybe you should try another font, so you can clearly distinguish l from 1)


Try this fixed .yaml file:


network:
version: 2
renderer: networkd
ethernets:
enp0s25:
dhcp4: true
enp6s0f1:
dhcp4: true
usb0:
dhcp4: false

[#106] Thursday, June 23, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
brailloni

Total Points: 122
Total Questions: 108
Total Answers: 108

Location: North Korea
Member since Tue, Apr 4, 2023
1 Year ago
brailloni questions
Thu, Jul 29, 21, 05:25, 3 Years ago
Sat, Apr 2, 22, 17:32, 2 Years ago
Mon, Oct 31, 22, 21:39, 2 Years ago
Fri, Dec 17, 21, 23:58, 2 Years ago
;