Monday, April 15, 2024
 Popular · Latest · Hot · Upcoming
1
rated 0 times [  1] [ 0]  / answers: 1 / hits: 477  / 2 Years ago, fri, april 1, 2022, 5:23:32

I am trying to install crossover for linux, on my Ubuntu 20.04 Mate installation, but the dependency python-gtk2 is missing.


sudo apt-get install python-gtk2 

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python-gtk2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-gtk2' has no installation candidate

I tried getting an older version for Ubuntu 18.04, but that wont install either.
it says the project is depreciated. That's all well and good, but I need it to run crossover.


enter image description here


what shall I do to satisfy this dependency?
enter image description here


More From » apt

 Answers
0

Ok, I guess I failed to mention having had a previous version of crossover already installed, which turns out was important. Installing using the deb file installer, showed no errors, during install, which made me think it was irrelevant.


in any event, I did sudo apt-get purge crossover, then ran the binary generic shell installer, which then ran successfully, and now crossover is now installed.


[#1768] Sunday, April 3, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
tonhorn

Total Points: 196
Total Questions: 118
Total Answers: 95

Location: Vanuatu
Member since Fri, May 13, 2022
2 Years ago
tonhorn questions
Tue, May 10, 22, 12:01, 2 Years ago
Sat, Dec 18, 21, 06:23, 2 Years ago
Thu, Jun 16, 22, 04:03, 2 Years ago
Tue, Nov 30, 21, 05:52, 2 Years ago
;