Tuesday, October 3, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  73] [ 0]  / answers: 1 / hits: 112971  / 2 Years ago, wed, march 16, 2022, 1:05:09

I am having trouble connecting my Bluetooth speakers with a fresh 15.10 install (EDIT: applies to 16.04 as well). The speakers are connected however they are not listed as an available audio device.

I tried to load the Bluetooth module using:

sudo pactl load-module module-bluetooth-discover
Failure: Module initialization failed

The same speakers have worked perfectly on 14.04. Any ideas how I could properly load the module so I can use my speakers?

More From » 16.04


Solved by using SimFox3 answer in this thread.

Bug and possible solution: actually I found a bug in that make the headset unusable, it seems that the pulse audio module: module-bluetooth-discover works only if started after the X11 session is up. So I have a workaround.

Edit the file:


and comment out (with an # at the beginning of the line) the following line:

#load-module module-bluetooth-discover

now edit the file:


and after the lines:

   if [ x”$SESSION_MANAGER” != x ] ; then
/usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null

add the following line:

    /usr/bin/pactl load-module module-bluetooth-discover

This way the Pulse audio’s Bluetooth modules will not be downloaded at boot time but after x11 is started.

[#17894] Wednesday, March 16, 2022, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 33
Total Questions: 136
Total Answers: 114

Location: Singapore
Member since Wed, Jan 13, 2021
3 Years ago