Thursday, September 21, 2023
rated 0 times [  203] [ 0]  / answers: 1 / hits: 327920  / 2 Years ago, fri, june 25, 2021, 11:43:12

I just installed Ubuntu 14.04 and I can't mount my exFAT HDD.

I get the following error:

Unable to access “SeagateHDD”
Error mounting /dev/sdb1 at /media/me/SeagateHDD: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/sdb1" "/media/me/SeagateHDD"' exited with non-zero exit status 1:
stdout: `FUSE exfat 1.0.1
stderr: `ERROR: `Operating Systems' has invalid checksum (0x281c != 0x2450).

I installed exfat-utils and exfat-fuse using apt-get but no luck.
I also tried the repository ppa:relan/exfat but I got:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
fuse-exfat : Depends: fuse-utils (>= 2.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

Can anybody give me a hint? All my backed up data is on that HDD.


The output of $ sudo apt-cache policy exfat-fuse is:

Installed: (none)
Candidate: 1.0.1-1
Version table:
1.0.1-1 0
500 trusty/main amd64 Packages

Tried it on a Linux Mint and had the same problem. Also tried mounting it on a Mac and it worked perfectly so the data is not corrupted.


It appears it was a problem with my HDD which apparently I unplugged from the USB port without unmounting and it had a checksum error. What I did was I plugged it on my Mac and it automatically did a fsck_exfat disk check which fixed the problem and I could load it on Ubuntu as well. I think a similar thing could be achieved on Ubuntu as well, but I don't know which tools to use to do so.

More From » partitioning


Installing the below packages alone will auto-mounts your exFAT formatted drives ,

sudo apt-get install exfat-fuse exfat-utils

Or you may try to mount it manually after installing the above packages,

sudo mkdir /media/exfat
sudo mount -t exfat /dev/sdxx /media/exfat

/dev/sdxx - your exfat partition.

In Ubuntu 14.04, exfat-fuse and exfat-utils packages are available in Universe repository. So enable this repository inorder to install these two packages on Ubuntu 14.04.

sudo add-apt-repository universe

And don't forget to update all repositories,

sudo apt-get update

[#25859] Saturday, June 26, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 298
Total Questions: 108
Total Answers: 106

Location: Bermuda
Member since Thu, Apr 20, 2023
6 Months ago