Thursday, September 21, 2023
 Popular · Latest · Hot · Upcoming
rated 0 times [  6] [ 0]  / answers: 1 / hits: 21672  / 2 Years ago, fri, november 26, 2021, 6:52:18

i'm trying to change from runlevel 5 to runlevel 3 by running sudo init 3 command.

for some reason it doesn't do anything anymore.

the weird thing is that if i run the command runlevel it shows me that i'm at level 3.

tried to run init 5 and then init 3 and still nothing.

does anybody knows how to fix it?

More From » init


From the manpages:

   Runlevels are a concept from UNIX(R)  System  V  used  by  the  init(8)
daemon or other system initialisation system to define modes of system
The Upstart init(8) daemon has no native concepts of runlevel, and
unlike the System V daemon, makes no attempt to keep track of the
current runlevel.

Ubuntu and other modern Linux distributions have replaced System V init with Upstart:

Upstart is an event-based replacement for the /sbin/init daemon which handles starting of tasks and services during boot, stopping them during shutdown and supervising them while the system is running.

If you must switch to what is now closest to runlevel 3 do it by stopping your gdm or lightdm service.

[#39706] Sunday, November 28, 2021, 2 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 336
Total Questions: 105
Total Answers: 113

Location: Vietnam
Member since Sun, Oct 18, 2020
3 Years ago
oargrou questions
Thu, May 13, 21, 16:38, 2 Years ago
Wed, Jul 21, 21, 01:38, 2 Years ago
Sat, May 15, 21, 17:39, 2 Years ago
Tue, May 24, 22, 14:58, 1 Year ago
Sat, Mar 19, 22, 05:22, 2 Years ago