Friday, September 29, 2023
rated 0 times [  1] [ 0]  / answers: 1 / hits: 525  / 11 Months ago, sat, november 19, 2022, 8:38:12

I created an extended partition and tried to add two NTFS units to it. Instead two 125 GB partitions, I got – according to Disk Utility – 2 X 982 GB partitions plus a 14574534 TB one (wahey!). I don't remember to have done anything weird.

The case is:

  • Neither Disk Utility, GParted or fdisk will let me fix/delete the extended partition, and in addition,

  • My LiveCD won't boot, although the BIOS order is correct and it worked perfectly before Ubuntu was installed. The hard drive installation of Ubuntu will start instead (edit – I got it to boot but having the drive unmounted does not fix the issue).

I guess I could try even more tools but I don't think this is that much of an unusual problem... what's the straight-forward solution for this?

Thank you in advance.

More From » partitioning


Okay so I managed to fix this, but in a pretty heterodox way I think.

As I said, my problem in particular consisted in an extended, infinisized-yet-empty, useless partition that couldn't be deleted with any of the usually recommended GNU tools for these cases.

It could be deleted with the Windows 7 installer. However, this messes up the whole partition table so you need to recover it using testdisk (no, I couldn't do this before the delete).

After this, you need to recover your GRUB with a CD or so.

I hope this helps someone in the future.

[#44641] Sunday, November 20, 2022, 11 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.

Total Points: 330
Total Questions: 111
Total Answers: 95

Location: Sint Maarten
Member since Tue, Mar 29, 2022
2 Years ago