Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
24
rated 0 times [  24] [ 0]  / answers: 1 / hits: 46753  / 12 Months ago, tue, april 4, 2023, 2:30:53

I have a conky setup that I've used on a number of desktops (here's the conkyrc). It works fine in Ubuntu Unity, XFCE, Gnome and Openbox, but not Lubuntu (LXDE). The problem is that I cannot get it to stay on the Lubuntu LXDE desktop reliably. Either the conky window disappears if I click the desktop or if I minimize all windows (show desktop).



I've tried all variations in the configuration file for "own_window", "own_window_colour", "own_window_transparent" and "own_window_type" and have Googled quite a bit to resolve this. If it edit the conkyrc file and set the own_window_type to "normal", conky disappears if I minimize all windows. If I set it to "desktop" it disappears if I click anywhere on the desktop. If I use "override" it doesn't display at all. And the other options don't work well for obvious reasons.



On another Ubuntu Unity install I had a similar problem, but got around it by using Compiz Config Settings Manager to ignore my conky window. On my netbook Lubuntu install I don't have compiz installed.



How can I get conky to stay on my desktop.


More From » lubuntu

 Answers
0

Seems like setting window type to desktop is not enough sometimes.



Try:



own_window_type desktop
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager


Got it from here.



Works for me in XFCE. I'm guessing it'll be fine for lxde/openbox as well.


[#35879] Wednesday, April 5, 2023, 12 Months  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
aciousoun

Total Points: 178
Total Questions: 110
Total Answers: 98

Location: Lithuania
Member since Fri, Sep 4, 2020
4 Years ago
;