Thursday, February 22, 2024
 Popular · Latest · Hot · Upcoming
4
rated 0 times [  4] [ 0]  / answers: 1 / hits: 5539  / 1 Year ago, thu, february 16, 2023, 5:09:20

I had been running Mint 12 before, and everything was working there. I switched to Ubuntu 12.04, and now I am very frustrated.



When I run ndk-build, I get



/home/buzz/ndk/prebuilt/linux-x86/bin/make: not found


So, I changed to that folder directly. When I type in ./make, I get



bash: ./make: No such file or directory


Typing ls clearly shows the file where I am! I did some hacking around (pointing to external tools) to get past each error (just to experiment), and I ran into this!



/home/buzz/ndk/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86/bin/arm-linux-androideabi-gcc: Command not found


Why? Why are all these files unable to be found? As I said above, this was all working just fine in another distro. What changed? What's extra frustrating is that if I push TAB to auto-complete, it works. So, the file is clearly there (and clearly marked with execution permissions). So, why can't it be found?


More From » 12.04

 Answers
5

I found the answer.



I installed ia32-libs, and everything started working. It's bizarre that running an executable of the wrong architecture results in "command not found". I was trying all the wrong things.


[#36612] Thursday, February 16, 2023, 1 Year  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
aciousoun

Total Points: 178
Total Questions: 110
Total Answers: 98

Location: Lithuania
Member since Fri, Sep 4, 2020
4 Years ago
;