Saturday, May 18, 2024
 Popular · Latest · Hot · Upcoming
0
rated 0 times [  0] [ 0]  / answers: 1 / hits: 3480  / 3 Years ago, tue, august 24, 2021, 2:19:04

ubuntu 18.04 software-properties-gtk failing when I try to open the software&update it doesn't open and when I tried to sudo software-properties-gtk


it return this error


ERROR:dbus.proxies:Introspect error on :1.136:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
Traceback (most recent call last):
File "/usr/bin/software-properties-gtk", line 100, in <module>
app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)
File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 173, in __init__
self.backend.Reload();
File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 70, in __call__
return self._proxy_method(*args, **keywords)
File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 145, in __call__
**keywords)
File "/usr/lib/python3/dist-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.136 was not provided by any .service files

I tried to reinstall software-properties-gtk but it didn't work
I also tried to reinstall python-six packages as recommended by other blogs but also didn't solve my issue.


More From » 18.04

 Answers
0

Try the following


sudo apt reinstall python3-six python3-certifi

I had months suffering from this issue on both 18.04 and 20.04. I came by this answer on one of the forums and it worked.


[#2698] Wednesday, August 25, 2021, 3 Years  [reply] [flag answer]
Only authorized users can answer the question. Please sign in first, or register a free account.
aciousoun

Total Points: 178
Total Questions: 110
Total Answers: 98

Location: Lithuania
Member since Fri, Sep 4, 2020
4 Years ago
;